Блог Александра Бурченко

  • Архив

    «   Сентябрь 2016   »
    Пн Вт Ср Чт Пт Сб Вс
          1 2 3 4
    5 6 7 8 9 10 11
    12 13 14 15 16 17 18
    19 20 21 22 23 24 25
    26 27 28 29 30    

Гарнитура .Audio 622 от Plantronics

Здравствуйте, Товарищи.

Недавно случилась со мной такая история. Пришел домой, включил ноут и собрался спокойно посмотреть какое-то видео(!). При попытке воткнуть наушники в разъем меня слегка оглушило статикой. Когда попытка подключения увенчалась успехом, звук из наушников пошел скрипучий и не ровный. Вообщем случилось так, что я спалил аудиовыход на звуковой карте. Не долго погоревав я уже было хотел нести ноут в ремонт, но наткнулся в каталоге наших партнеров на гарнитуру (наушники+микрофон) с волшебными буквами "USB". Это означало, что посмотреть какое-то видео(!), не мешая при этом окружающим, таки мне удастся не перепаивая звуковую карту в ноуте. Ассортимент в каталоге оказался приличный, но я остановился на модели .Audio 622 ибо она совместима с Windows, подключается к USB и стоит при этом совсем не дорого.

Читать подробнее...

Фото:

Обзор Opticon SMART и интеграция его с 1С

Здравствуйте Товарищи!
Opticon SMART

Opticon SMART - терминал сбора данных (ТСД) готовый к работе почти сразу после покупки.

Читать подробнее...

Фото:

Модуль связи 1С и Asterisk

Предлагаю вашему вниманию обработку экспорта данных из Asterisk в 1С.
К сожалению доступен пока только основной функционал, но его достаточно для реализации многих задач.
Для внедрения модуля необходимо внести изменения в глобальный модуль конфигурации. Код приведен ниже:
Процедура ПриНачалеРаботыСистемы()
   . . .
   // Запуск компонента Asterisk1C
   Попытка
      Asterisk1C = 0;
      ПодключитьВнешнююКомпоненту("Asterisk1C");
      Если Asterisk1C = 0 Тогда
         Попытка
            Asterisk1C = ПолучитьCOMОбъект( , "Asterisk1C");
         Исключение
            Asterisk1C = 0;
         КонецПопытки;
      КонецЕсли;

      Если Asterisk1C = 0 Тогда
         Попытка
            Asterisk1C = ПолучитьCOMОбъект( "", "Asterisk1C");
         Исключение
            Asterisk1C = 0;
            Предупреждение(ОписаниеОшибки());
         КонецПопытки;
      КонецЕсли;

      Если Asterisk1C <> 0 Тогда
         Asterisk1C.Connect("192.168.1.110", 5038, "client1C", "client1c8pass");
         Asterisk1C.AgentLogin("201", "105");
         // Если нужно дождаться завершения входа агента
         Пока Не(Asterisk1C.IsAgentLogin()) Цикл
            Asterisk1C.Sleep(500);
         КонецЦикла;
         // This is for test
         Asterisk1C.AgentPause();
         Asterisk1C.AgentUnPause();
         Asterisk1C.Originate("1234567", "internal", 20);
      Иначе
         Предупреждение("Компонент Asterisk1C не загружен");
      КонецЕсли;
   Исключение
      Asterisk1C = 0;
      Предупреждение(ОписаниеОшибки());
   КонецПопытки;

КонецПроцедуры // ПриНачалеРаботыСистемы()

Процедура ПриЗавершенииРаботыСистемы()
   . . .
   Если Asterisk1C <> 0 Тогда
      Попытка
         Asterisk1C.AgentLogoff();
         // Если нужно дождаться завершения выхода агента
         Пока Asterisk1C.IsAgentLogin() Цикл
            Asterisk1C.Sleep(500);
         КонецЦикла;
         Asterisk1C.Disconnect();
         Asterisk1C = 0;
      Исключение
         Asterisk1C = 0;
         Предупреждение(ОписаниеОшибки());
      КонецПопытки;
   КонецЕсли;
КонецПроцедуры
Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
   Если Источник = "Asterisk1C" Тогда
      // Событие – Звонок на зарегистрированного агента
      Если Событие = "Ringing" Тогда
         ЗаписьЖурналаРегистрации(Источник + " - " + Событие,
            УровеньЖурналаРегистрации.Информация,
            ,
            ,
            "From: " + Asterisk1C.GetField(Данные, "CallerID") +
            " To: " + Asterisk1C.GetField(Данные, "CallingNumber")
            );
      Иначе
         ЗаписьЖурналаРегистрации(Источник + " - " + Событие,
            УровеньЖурналаРегистрации.Информация,
            ,
            ,
            Данные
            );
      КонецЕсли;
      Возврат;
   КонецЕсли;
   . . .
КонецПроцедуры // ОбработкаВнешнегоСобытия()

В строках:
Asterisk1C.Connect("192.168.1.110", 5038, "client1C", "client1c8pass");
Asterisk1C.AgentLogin("201", "105");

необходимо указать ваши реквизиты подключения.
Так же потребуется изменение диалплана на Астериск. Подробнее описано тут.