Блог Александра Бурченко

  • Архив

    «   Июль 2017   »
    Пн Вт Ср Чт Пт Сб Вс
              1 2
    3 4 5 6 7 8 9
    10 11 12 13 14 15 16
    17 18 19 20 21 22 23
    24 25 26 27 28 29 30
    31            

Обзор ТСД MobileBase DS5

Недавно одному из наших клиентов, который занимается оптовой торговлей продуктов питания, нами был внедрен Терминал сбора данных MobileBase DS5.
Поскольку склад большой площади, постоянные перемещения товаров и удаленность рабочей базы данных не позволяли оперативно справляться со всеми задачами, стоящими перед персоналом.
К решению приобрести именно этот терминал привел ряд факторов:

  1. Суровые погодные условия в зоне приемки/выгрузки, далеко не благоприятнейшие даже на складе;
  2. Высокие стеллажи обуславливали возможность падения такой недешевой техники;
  3. Необходимость работы без непосредственного подключения к рабочей станции.

Итак, на нижеприведенной фотографии изображена комплектация данного устройства.
1.jpg
Сам терминал имеет эргономичную форму и, несмотря на экран в 3,5 дюйма с вынесенной клавиатурой, очень удобно лежит в руке. Экран сенсорный, что позволяет быстро набирать текст на небольшой qwerty-клавиатуре при помощи комплектного стилуса. Хотя основные операции предусмотрено производить без его помощи через основную прорезиненную 35-клавишную клавиатуру.
2.jpg
В комплекте с ТСД идет кредл для возможности подключения его к ПК и синхронизации через ActiveSync/Центр устройств WM, а также зарядки как самого ТСД, так и аккумулятора отдельно (допустим при использовании еще одного аккумулятора для совсем бесперебойной работы).
3.jpg
Пистолетная рукоятка для удобства использования в полевых условиях не входит в основную поставку (ее цена за такой функционал мне показалась завышенной).
4.jpg
Все это удовольствие упаковано в компактную коробку.
5.jpg
Терминал работает на Windows Embedded Handheld 6.5.
6.jpg7.jpg
Т.к. основным требованием было использование сети WiFi для связи ТСД – Сервер 1С, то MobileLogistics, в основном используемый нами ранее, для этого уже не подходил. Поэтому было решено применить MobileSMARTS 1C-WIFI драйвер от Cleverence. Тем более, что сам драйвер, включающий базовые складские конфигурации, стоил чуть больше, чем привычный стационарный драйвер от MobileLogistics. При установке на терминал (первичная загрузка через кредл) приложение автоматически встраивается в автозагрузку, а также при запуске само подключает сканирующий модуль.
8.jpg9.jpg10.jpg
Критический для нас параметр (уровень сигнала WiFi) был измерен сначала в офисном здании (среди шумов электропроводки, освещения и других радиопомех): на первом фото сигнал рядом с роутером NetGear 3500, на втором через 20 метров и гипсокартонную стенку, а на третьем на таком же расстоянии плюс ЖБ-перекрытие. Честно говоря, был не впечатлен результатами. В условиях склада же устройство показало себя во всей красе: вся зона погрузки, а это ЖБ-плита + два слоя профнастила на расстоянии 12 метров от источника сигнала, и вся площадь склада радиусом более 50 м. была покрыта достаточным уровнем сигнала WiFi для обмена с сервером 1С.
11.jpg12.jpg13.jpg
Все это, а также факт того, что с ТСД можно работать и в мороз, и в дождь, а также ронять чуть менее чем с двухметровой высоты, позволяет с уверенностью сказать, что корейцы не зря просят за него 1к зеленых.
Ниже приведу технические характеристики данного устройства.
14.png
Фото:

Гарнитура .Audio 622 от Plantronics

Здравствуйте, Товарищи.

Недавно случилась со мной такая история. Пришел домой, включил ноут и собрался спокойно посмотреть какое-то видео(!). При попытке воткнуть наушники в разъем меня слегка оглушило статикой. Когда попытка подключения увенчалась успехом, звук из наушников пошел скрипучий и не ровный. Вообщем случилось так, что я спалил аудиовыход на звуковой карте. Не долго погоревав я уже было хотел нести ноут в ремонт, но наткнулся в каталоге наших партнеров на гарнитуру (наушники+микрофон) с волшебными буквами "USB". Это означало, что посмотреть какое-то видео(!), не мешая при этом окружающим, таки мне удастся не перепаивая звуковую карту в ноуте. Ассортимент в каталоге оказался приличный, но я остановился на модели .Audio 622 ибо она совместима с Windows, подключается к USB и стоит при этом совсем не дорого.

Читать подробнее...

Фото:

Обзор Opticon SMART и интеграция его с 1С

Здравствуйте Товарищи!
Opticon SMART

Opticon SMART - терминал сбора данных (ТСД) готовый к работе почти сразу после покупки.

Читать подробнее...

Фото:

Модуль связи 1С и Asterisk

Предлагаю вашему вниманию обработку экспорта данных из Asterisk в 1С.
К сожалению доступен пока только основной функционал, но его достаточно для реализации многих задач.
Для внедрения модуля необходимо внести изменения в глобальный модуль конфигурации. Код приведен ниже:
Процедура ПриНачалеРаботыСистемы()
   . . .
   // Запуск компонента Asterisk1C
   Попытка
      Asterisk1C = 0;
      ПодключитьВнешнююКомпоненту("Asterisk1C");
      Если Asterisk1C = 0 Тогда
         Попытка
            Asterisk1C = ПолучитьCOMОбъект( , "Asterisk1C");
         Исключение
            Asterisk1C = 0;
         КонецПопытки;
      КонецЕсли;

      Если Asterisk1C = 0 Тогда
         Попытка
            Asterisk1C = ПолучитьCOMОбъект( "", "Asterisk1C");
         Исключение
            Asterisk1C = 0;
            Предупреждение(ОписаниеОшибки());
         КонецПопытки;
      КонецЕсли;

      Если Asterisk1C <> 0 Тогда
         Asterisk1C.Connect("192.168.1.110", 5038, "client1C", "client1c8pass");
         Asterisk1C.AgentLogin("201", "105");
         // Если нужно дождаться завершения входа агента
         Пока Не(Asterisk1C.IsAgentLogin()) Цикл
            Asterisk1C.Sleep(500);
         КонецЦикла;
         // This is for test
         Asterisk1C.AgentPause();
         Asterisk1C.AgentUnPause();
         Asterisk1C.Originate("1234567", "internal", 20);
      Иначе
         Предупреждение("Компонент Asterisk1C не загружен");
      КонецЕсли;
   Исключение
      Asterisk1C = 0;
      Предупреждение(ОписаниеОшибки());
   КонецПопытки;

КонецПроцедуры // ПриНачалеРаботыСистемы()

Процедура ПриЗавершенииРаботыСистемы()
   . . .
   Если Asterisk1C <> 0 Тогда
      Попытка
         Asterisk1C.AgentLogoff();
         // Если нужно дождаться завершения выхода агента
         Пока Asterisk1C.IsAgentLogin() Цикл
            Asterisk1C.Sleep(500);
         КонецЦикла;
         Asterisk1C.Disconnect();
         Asterisk1C = 0;
      Исключение
         Asterisk1C = 0;
         Предупреждение(ОписаниеОшибки());
      КонецПопытки;
   КонецЕсли;
КонецПроцедуры
Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
   Если Источник = "Asterisk1C" Тогда
      // Событие – Звонок на зарегистрированного агента
      Если Событие = "Ringing" Тогда
         ЗаписьЖурналаРегистрации(Источник + " - " + Событие,
            УровеньЖурналаРегистрации.Информация,
            ,
            ,
            "From: " + Asterisk1C.GetField(Данные, "CallerID") +
            " To: " + Asterisk1C.GetField(Данные, "CallingNumber")
            );
      Иначе
         ЗаписьЖурналаРегистрации(Источник + " - " + Событие,
            УровеньЖурналаРегистрации.Информация,
            ,
            ,
            Данные
            );
      КонецЕсли;
      Возврат;
   КонецЕсли;
   . . .
КонецПроцедуры // ОбработкаВнешнегоСобытия()

В строках:
Asterisk1C.Connect("192.168.1.110", 5038, "client1C", "client1c8pass");
Asterisk1C.AgentLogin("201", "105");

необходимо указать ваши реквизиты подключения.
Так же потребуется изменение диалплана на Астериск. Подробнее описано тут.
Цель нашей компании - предоставление высококачественных ИТ-услуг предприятиям малого и среднего бизнеса.